Технологии Blogger.

Как преобразовать дату в текст в Excel

Здравствуйте. Сегодня мы научимся преобразовывать дату в текст в Excel. Сначала давайте изучим как Эксель хранит информацию о дате. Программа хранит ее как число, равное количеству дней от 01.01.1900 года, к примеру 01.01.2016 это 42 370. Нам же нужно преобразовать это число в текст, к примеру что бы 01.01.2016 отразилось как 1 янв 2016 в текстовом формате. Это можно сделать при помощи встроенной формулы ТЕКСТ.

Как преобразовать дату в текст в Excel

Синтаксис формулы:

ТЕКСТ(значение; формат)

где значение - это ссылка на ячейку с датой, либо сама дата.
      формат - Численный формат в виде текстовой строки в кавычках.

Варианты форматов для приобразования даты:

МОтображение месяца в виде числа без начального нуля.
ММОтображение месяца в виде числа с начальным нулем, если он необходим.
МММОтображение сокращенного названия месяца (янв–дек).
ММММОтображение полного названия месяца (январь–декабрь).
МММММОтображение месяца в виде одной буквы (Я–Д).
ДОтображение дня в виде числа без начального нуля.
ДДОтображение дня в виде числа с начальным нулем, если он необходим.
ДДДОтображение сокращенного названия дня недели (пн–вс).
ДДДДОтображение полного названия дня недели (понедельник–воскресенье).
ГГОтображение года в виде двузначного числа.
ГГГГОтображение года в виде четырехзначного числа.

В нашем случае введите в ячейку A1 нашу дату 01.01.2016, а в ячейку B1 формулу =ТЕКСТ(A1;"ДД МММ ГГГГ"), тем самым Вы получите в ячейке В1 текст "01 янв 2016", который мы и хотели получить.

Оставляйте комментарии к статье ниже.
Опубликовать в Google Plus