data_client

Технологии Blogger.

Как преобразовать дату в текст в Excel

Здравствуйте. Сегодня мы научимся преобразовывать дату в текст в Excel. Сначала давайте изучим как Эксель хранит информацию о дате. Программа хранит ее как число, равное количеству дней от 01.01.1900 года, к примеру 01.01.2016 это 42 370. Нам же нужно преобразовать это число в текст, к примеру что бы 01.01.2016 отразилось как 1 янв 2016 в текстовом формате. Это можно сделать при помощи встроенной формулы ТЕКСТ.

Как преобразовать дату в текст в Excel

Синтаксис формулы:

ТЕКСТ(значение; формат)

где значение - это ссылка на ячейку с датой, либо сама дата.
      формат - Численный формат в виде текстовой строки в кавычках.

Варианты форматов для приобразования даты:

МОтображение месяца в виде числа без начального нуля.
ММОтображение месяца в виде числа с начальным нулем, если он необходим.
МММОтображение сокращенного названия месяца (янв–дек).
ММММОтображение полного названия месяца (январь–декабрь).
МММММОтображение месяца в виде одной буквы (Я–Д).
ДОтображение дня в виде числа без начального нуля.
ДДОтображение дня в виде числа с начальным нулем, если он необходим.
ДДДОтображение сокращенного названия дня недели (пн–вс).
ДДДДОтображение полного названия дня недели (понедельник–воскресенье).
ГГОтображение года в виде двузначного числа.
ГГГГОтображение года в виде четырехзначного числа.

В нашем случае введите в ячейку A1 нашу дату 01.01.2016, а в ячейку B1 формулу =ТЕКСТ(A1;"ДД МММ ГГГГ"), тем самым Вы получите в ячейке В1 текст "01 янв 2016", который мы и хотели получить.

Оставляйте комментарии к статье ниже.

5 comments:

  1. Доброго времени!
    ввожу в ячейку формулу как в примере а у меня вместо даты пишет "ДД.ММ.ГГГГ"

    ОтветитьУдалить
    Ответы
    1. Вероятнее всего вы попутали местами в формуле ссылку на дату и формат. У вас скорее всего формула: =ТЕКСТ("ДД.ММ.ГГГГ";A1), а должна быть =ТЕКСТ(A1;"ДД.ММ.ГГГГ")

      Удалить
    2. ДД.ММ.ГГГГ заміни на DD.MM.YYYY

      Удалить
  2. Доброе утро!
    Почему при вводе данной формулы ТЕКСТ(D5;"дд.мм.гггг") выводится 18.00.2020
    Те. вместо месяца выводит 00?

    ОтветитьУдалить
  3. Та же фигня. Нашёл причину - надо формат вводить ЗАГЛАВНЫМИ буквами, тогда работает корректно. Т.е. формула выглядит так: ТЕКСТ(D5;"ДД.ММ.ГГГГ"). Но, вообще, возможны варианты в зависимости от того, где зарегистрирован комп. В Германии, Швейцарии, Штатах форматы выглядят по-другому.

    ОтветитьУдалить

Спасибо за комментарий.