data_client

Технологии Blogger.

Как исправить ошибку #ДЕЛ/0! в Excel

При работе в Excel вы можете столкнуться с ошибкой #ДЕЛ/0, которая значит что вы пытаетесь поделить число на 0, а как вы знаете, делить на 0 нельзя. Исправить эту ошибку в Экселе можно несколькими способами.

Как исправить ошибку #ДЕЛ/0! в Excel

Способ 1. При помощи функции ЕСЛИ

При помощи функции ЕСЛИ() мы сможем обработать ситуацию, при которой числитель равен 0. Синтаксис функции следующий ЕСЛИ(условие; результат при верном значении; результат при неверном значении). В примере выше мы должны проверить, является ли значение в ячейке С4 равно 0, если равно 0, то присваиваем значение "-", а если нет - то вычисляем значение от деления. Итого формула выглядит так: =ЕСЛИ(C4=0;"-";C3/C4)

Как исправить ошибку #ДЕЛ/0! в Excel

Способ 2. При помощи функции ЕСЛИОШИБКА

Функция ЕСЛИОШИБКА возвращает заданное значение, если в ячейке ошибка, иначе вычисляет заданную формулу. Синтаксис функции следующий  ЕСЛИОШИБКА(Формула; Значение если ошибка). В нашем случае будет так: =ЕСЛИОШИБКА(C3/C4;"-")
 
Как исправить ошибку #ДЕЛ/0! в Excel

Спасибо, что прочитали статью. Теперь вы знаете, как исправить ошибку #ДЕЛ/0 в Excel. Есть вопросы - добро пожаловать в комментарии ;)
Опубликовать в Google Plus